re = /^(?!.*[a-zA-Z])\W*(\d+)\W*$/m
str = '(5)
[[12]]
{3}
#!8(#
!255=
/879/
@#@434dsd@#2'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result