import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*[a-zA-Z])\\W*(\\d+)\\W*$";
final String string = "(5)\n"
+ "[[12]]\n"
+ "{3}\n"
+ "#!8(#\n"
+ "!255=\n"
+ "/879/\n"
+ "@#@434dsd@#2";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}