using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!\d+$)(?!.*(?:Test|pimba|vraw))\w{8,}$";
string input = @"abcd1234
12345678
foo
foo-bar-baz
123456aaavraw";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}