re = /^(?!\d+$)(?!.*(?:Test|pimba|vraw))\w{8,}$/m
str = 'abcd1234
12345678
foo
foo-bar-baz
123456aaavraw'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end