import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!\\d+$)(?!.*(?:Test|pimba|vraw))\\w{8,}$";
final String string = "abcd1234\n"
+ "12345678\n"
+ "foo\n"
+ "foo-bar-baz\n"
+ "123456aaavraw";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}