$re = '/^(?!\d+$)(?!.*(?:Test|pimba|vraw))\w{8,}$/m';
$str = 'abcd1234
12345678
foo
foo-bar-baz
123456aaavraw';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);