const regex = /^(?!\d+$)(?!.*(?:Test|pimba|vraw))\w{8,}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!\\d+$)(?!.*(?:Test|pimba|vraw))\\w{8,}$', 'gm')
const str = `abcd1234
12345678
foo
foo-bar-baz
123456aaavraw`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}