#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((?s)(<START>.*?)(?:(?:\r*\n){2}|<STOP>|\Z)){0,4}"
Local $sString = "<START> some text is here. " & @CRLF & _
"more text" & @CRLF & _
"more text" & @CRLF & _
"more text" & @CRLF & _
"too long" & @CRLF & _
"" & @CRLF & _
"<DON'T CAPTURE ME> unrelated text" & @CRLF & _
"" & @CRLF & _
"<START> even more text. " & @CRLF & _
"text text" & @CRLF & _
"" & @CRLF & _
"<START> even more text. " & @CRLF & _
"text text"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")