using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?s)(<START>.*?)(?:(?:\r*\n){2}|<STOP>|\Z)){0,4}";
string input = @"<START> some text is here.
more text
more text
more text
too long
<DON'T CAPTURE ME> unrelated text
<START> even more text.
text text
<START> even more text.
text text";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}