$re = '/((?s)(<START>.*?)(?:(?:\r*\n){2}|<STOP>|\Z)){0,4}/m';
$str = '<START> some text is here.
more text
more text
more text
too long
<DON\'T CAPTURE ME> unrelated text
<START> even more text.
text text
<START> even more text.
text text';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);