import re
regex = re.compile(r"((?s)(<START>.*?)(?:(?:\r*\n){2}|<STOP>|\Z)){0,4}", flags=re.MULTILINE)
test_str = ("<START> some text is here. \n"
"more text\n"
"more text\n"
"more text\n"
"too long\n\n"
"<DON'T CAPTURE ME> unrelated text\n\n"
"<START> even more text. \n"
"text text\n\n"
"<START> even more text. \n"
"text text")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")