// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)((?s)(<START>.*?)(?:(?:\r*\n){2}|<STOP>|\Z)){0,4}").unwrap();
let string = "<START> some text is here.
more text
more text
more text
too long
<DON'T CAPTURE ME> unrelated text
<START> even more text.
text text
<START> even more text.
text text";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}