using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"20241118";
string input = @"s3://snowflake-iagedh-dev/cxone/telemetry/20241118112007_changed_data_activity_fact_view_v001.csv";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}