$re = '/20241118/';
$str = 's3://snowflake-iagedh-dev/cxone/telemetry/20241118112007_changed_data_activity_fact_view_v001.csv';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);