re = /20241118/
str = 's3://snowflake-iagedh-dev/cxone/telemetry/20241118112007_changed_data_activity_fact_view_v001.csv'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end