import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([a-zA-Z]{1,2}\\d{1,2}[a-zA-Z]{0,2})\\s*?(\\d[a-zA-Z]{2})$";
final String string = "m20 5qj\n"
+ "BS3 1JP\n"
+ "bs3 1jp\n"
+ "m5 8wa\n"
+ "m205qj\n"
+ "Bs31JP\n\n"
+ "http://en.wikipedia.org/wiki/Postcodes_in_the_United_Kingdom#Validation\n\n"
+ "AA9A 9AA\n"
+ "A9A 9AA\n"
+ "A9 9AA\n"
+ "A99 9AA\n"
+ "AA9 9AA\n"
+ "AA99 9AA\n\n"
+ "aa9A9AA\n"
+ "A9A9AA\n"
+ "A99AA\n"
+ "A999AA\n"
+ "AA99AA\n"
+ "AA999AA";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}