import re
regex = re.compile(r"^([a-zA-Z]{1,2}\d{1,2}[a-zA-Z]{0,2})\s*?(\d[a-zA-Z]{2})$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("m20 5qj\n"
"BS3 1JP\n"
"bs3 1jp\n"
"m5 8wa\n"
"m205qj\n"
"Bs31JP\n\n"
"http://en.wikipedia.org/wiki/Postcodes_in_the_United_Kingdom#Validation\n\n"
"AA9A 9AA\n"
"A9A 9AA\n"
"A9 9AA\n"
"A99 9AA\n"
"AA9 9AA\n"
"AA99 9AA\n\n"
"aa9A9AA\n"
"A9A9AA\n"
"A99AA\n"
"A999AA\n"
"AA99AA\n"
"AA999AA")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")