re = /^([a-zA-Z]{1,2}\d{1,2}[a-zA-Z]{0,2})\s*?(\d[a-zA-Z]{2})$/mi
str = 'm20 5qj
BS3 1JP
bs3 1jp
m5 8wa
m205qj
Bs31JP
http://en.wikipedia.org/wiki/Postcodes_in_the_United_Kingdom#Validation
AA9A 9AA
A9A 9AA
A9 9AA
A99 9AA
AA9 9AA
AA99 9AA
aa9A9AA
A9A9AA
A99AA
A999AA
AA99AA
AA999AA'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end