const regex = /^([a-zA-Z]{1,2}\d{1,2}[a-zA-Z]{0,2})\s*?(\d[a-zA-Z]{2})$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([a-zA-Z]{1,2}\\d{1,2}[a-zA-Z]{0,2})\\s*?(\\d[a-zA-Z]{2})$', 'gmi')
const str = `m20 5qj
BS3 1JP
bs3 1jp
m5 8wa
m205qj
Bs31JP
http://en.wikipedia.org/wiki/Postcodes_in_the_United_Kingdom#Validation
AA9A 9AA
A9A 9AA
A9 9AA
A99 9AA
AA9 9AA
AA99 9AA
aa9A9AA
A9A9AA
A99AA
A999AA
AA99AA
AA999AA`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}