#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?s)<a\s[^>]*?href\s*=\s*\\'https?://site\.ru/[^>]+>\s*<img.+?</a>"
Local $sString = "<a class=\'fancybox\' href=\'http://site.ru/upload/manuals/3V/image_2022_01_28T12_03_17_757Z.jpg\' rel=\'group\'><img src=\'http://site.ru/upload/manuals/3V/image_2022_01_28T12_03_17_757Z.jpg\' width=\'400px\'></img></a>" & @CRLF & _
"<a class=\'fancybox\' href=\'http://site2.ru/upload/manuals/3V/image_2022_01_28T12_03_17_757Z.jpg\' rel=\'group\'><img src=\'http://site2.ru/upload/manuals/3V/image_2022_01_28T12_03_17_757Z.jpg\' width=\'400px\'></img></a>" & @CRLF & _
"<a class=\'fancybox\' href=\'http://site.ru/upload/manuals/3V/image_2022_01_28T12_03_17_757Z.jpg\' rel=\'group\'><img src=\'http://site.ru/upload/manuals/3V/image_2022_01_28T12_03_17_757Z.jpg\' width=\'400px\'></img></a>"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)