# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<a\s[^>]*?href\s*=\s*\\'https?://site\.ru/[^>]+>\s*<img.+?</a>"
test_str = ("<a class=\\'fancybox\\' href=\\'http://site.ru/upload/manuals/3V/image_2022_01_28T12_03_17_757Z.jpg\\' rel=\\'group\\'><img src=\\'http://site.ru/upload/manuals/3V/image_2022_01_28T12_03_17_757Z.jpg\\' width=\\'400px\\'></img></a>\n"
"<a class=\\'fancybox\\' href=\\'http://site2.ru/upload/manuals/3V/image_2022_01_28T12_03_17_757Z.jpg\\' rel=\\'group\\'><img src=\\'http://site2.ru/upload/manuals/3V/image_2022_01_28T12_03_17_757Z.jpg\\' width=\\'400px\\'></img></a>\n"
"<a class=\\'fancybox\\' href=\\'http://site.ru/upload/manuals/3V/image_2022_01_28T12_03_17_757Z.jpg\\' rel=\\'group\\'><img src=\\'http://site.ru/upload/manuals/3V/image_2022_01_28T12_03_17_757Z.jpg\\' width=\\'400px\\'></img></a>")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.DOTALL)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.