package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)<a\s[^>]*?href\s*=\s*\\'https?://site\.ru/[^>]+>\s*<img.+?</a>`)
var str = `<a class=\'fancybox\' href=\'http://site.ru/upload/manuals/3V/image_2022_01_28T12_03_17_757Z.jpg\' rel=\'group\'><img src=\'http://site.ru/upload/manuals/3V/image_2022_01_28T12_03_17_757Z.jpg\' width=\'400px\'></img></a>
<a class=\'fancybox\' href=\'http://site2.ru/upload/manuals/3V/image_2022_01_28T12_03_17_757Z.jpg\' rel=\'group\'><img src=\'http://site2.ru/upload/manuals/3V/image_2022_01_28T12_03_17_757Z.jpg\' width=\'400px\'></img></a>
<a class=\'fancybox\' href=\'http://site.ru/upload/manuals/3V/image_2022_01_28T12_03_17_757Z.jpg\' rel=\'group\'><img src=\'http://site.ru/upload/manuals/3V/image_2022_01_28T12_03_17_757Z.jpg\' width=\'400px\'></img></a>`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}