import Foundation
let pattern = #"<a\s[^>]*?href\s*=\s*\\'https?://site\.ru/[^>]+>\s*<img.+?</a>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .dotMatchesLineSeparators)
let testString = #"""
<a class=\'fancybox\' href=\'http://site.ru/upload/manuals/3V/image_2022_01_28T12_03_17_757Z.jpg\' rel=\'group\'><img src=\'http://site.ru/upload/manuals/3V/image_2022_01_28T12_03_17_757Z.jpg\' width=\'400px\'></img></a>
<a class=\'fancybox\' href=\'http://site2.ru/upload/manuals/3V/image_2022_01_28T12_03_17_757Z.jpg\' rel=\'group\'><img src=\'http://site2.ru/upload/manuals/3V/image_2022_01_28T12_03_17_757Z.jpg\' width=\'400px\'></img></a>
<a class=\'fancybox\' href=\'http://site.ru/upload/manuals/3V/image_2022_01_28T12_03_17_757Z.jpg\' rel=\'group\'><img src=\'http://site.ru/upload/manuals/3V/image_2022_01_28T12_03_17_757Z.jpg\' width=\'400px\'></img></a>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)