import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<a\\s[^>]*?href\\s*=\\s*\\\\'https?://site\\.ru/[^>]+>\\s*<img.+?</a>";
final String string = "<a class=\\'fancybox\\' href=\\'http://site.ru/upload/manuals/3V/image_2022_01_28T12_03_17_757Z.jpg\\' rel=\\'group\\'><img src=\\'http://site.ru/upload/manuals/3V/image_2022_01_28T12_03_17_757Z.jpg\\' width=\\'400px\\'></img></a>\n"
+ "<a class=\\'fancybox\\' href=\\'http://site2.ru/upload/manuals/3V/image_2022_01_28T12_03_17_757Z.jpg\\' rel=\\'group\\'><img src=\\'http://site2.ru/upload/manuals/3V/image_2022_01_28T12_03_17_757Z.jpg\\' width=\\'400px\\'></img></a>\n"
+ "<a class=\\'fancybox\\' href=\\'http://site.ru/upload/manuals/3V/image_2022_01_28T12_03_17_757Z.jpg\\' rel=\\'group\\'><img src=\\'http://site.ru/upload/manuals/3V/image_2022_01_28T12_03_17_757Z.jpg\\' width=\\'400px\\'></img></a>";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}