#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(.*\.\d{1,})$"
Local $sString = "name." & @CRLF & _
"File Name." & @CRLF & _
"name.abc" & @CRLF & _
"name.1" & @CRLF & _
"name.123" & @CRLF & _
"name.123.abc" & @CRLF & _
"File name.aaa.123"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")