$re = '/^(.*\.\d{1,})$/m';
$str = 'name.
File Name.
name.abc
name.1
name.123
name.123.abc
File name.aaa.123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);