package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(.*\.\d{1,})$`)
var str = `name.
File Name.
name.abc
name.1
name.123
name.123.abc
File name.aaa.123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}