import re
regex = re.compile(r"^(.*\.\d{1,})$", flags=re.MULTILINE)
test_str = ("name.\n"
"File Name.\n"
"name.abc\n"
"name.1\n"
"name.123\n"
"name.123.abc\n"
"File name.aaa.123")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")