#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?!^)(?=(?:\d{3})+$)"
Local $sString = "12345678" & @CRLF & _
"123" & @CRLF & _
"1" & @CRLF & _
"1234" & @CRLF & _
"123456" & @CRLF & _
"778123232232"
Local $sSubst = ","
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)