const regex = new RegExp('(?!^)(?=(?:\\d{3})+$)', 'gm')
const str = `12345678
123
1
1234
123456
778123232232`;
const subst = `,`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);