import re
regex = re.compile(r"(?!^)(?=(?:\d{3})+$)", flags=re.MULTILINE)
test_str = ("12345678\n"
"123\n"
"1\n"
"1234\n"
"123456\n"
"778123232232")
subst = ","
result = regex.sub(subst, test_str)
if result:
print(result)