$re = '/(?!^)(?=(?:\d{3})+$)/m';
$str = '12345678
123
1
1234
123456
778123232232';
$subst = ",";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;