import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(@)?(https?:)?(\\/\\/)?(www\\.)?(([a-z0-9\\p{L}][a-z0-9\\p{L}-\\.]{1,61})([a-z0-9\\p{L}]\\.[a-z0-9\\p{L}][a-z\\p{L}-])*([a-z0-9\\p{L}])+\\/)?(#!\\/)?([a-z0-9][a-z0-9.]{1,61})([\\/|\\?].*)*$";
final String string = "http://xn--80adtDgbbrh1bc.xn--p1ai/pavel.durov\n\n"
+ "http://www.twitter.com/codeschool\n\n"
+ "https://www.twitter.com/dssd\n\n"
+ "http://www.twitter.com/#!/donttrythis\n\n"
+ "http://twitter.com/KimKardashian\n\n"
+ "http://www.twitter.com/#!/KourtneyKardash/following\n\n"
+ "http://twitter.com/#!/jasonterry31/lists/memberships\n\n"
+ "https://vk.com/igor.suvorov\n"
+ "https://tWitter.com/suvorovigor\n"
+ "https://telegram.me/skillbranch\n"
+ "@skillbranch\n"
+ "https://vk.com/skillbranch\n"
+ "https://vk.com/skillbranch?w=wall-117903599_1076";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}