$re = '/^(@)?(https?:)?(\/\/)?(www\.)?(([a-z0-9\p{L}][a-z0-9\p{L}-\.]{1,61})([a-z0-9\p{L}]\.[a-z0-9\p{L}][a-z\p{L}-])*([a-z0-9\p{L}])+\/)?(#!\/)?([a-z0-9][a-z0-9.]{1,61})([\/|\?].*)*$/mi';
$str = 'http://xn--80adtDgbbrh1bc.xn--p1ai/pavel.durov
http://www.twitter.com/codeschool
https://www.twitter.com/dssd
http://www.twitter.com/#!/donttrythis
http://twitter.com/KimKardashian
http://www.twitter.com/#!/KourtneyKardash/following
http://twitter.com/#!/jasonterry31/lists/memberships
https://vk.com/igor.suvorov
https://tWitter.com/suvorovigor
https://telegram.me/skillbranch
@skillbranch
https://vk.com/skillbranch
https://vk.com/skillbranch?w=wall-117903599_1076';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);