import re
regex = re.compile(r"^(@)?(https?:)?(\/\/)?(www\.)?(([a-z0-9\p{L}][a-z0-9\p{L}-\.]{1,61})([a-z0-9\p{L}]\.[a-z0-9\p{L}][a-z\p{L}-])*([a-z0-9\p{L}])+\/)?(#!\/)?([a-z0-9][a-z0-9.]{1,61})([\/|\?].*)*$", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("http://xn--80adtDgbbrh1bc.xn--p1ai/pavel.durov\n\n"
"http://www.twitter.com/codeschool\n\n"
"https://www.twitter.com/dssd\n\n"
"http://www.twitter.com/#!/donttrythis\n\n"
"http://twitter.com/KimKardashian\n\n"
"http://www.twitter.com/#!/KourtneyKardash/following\n\n"
"http://twitter.com/#!/jasonterry31/lists/memberships\n\n"
"https://vk.com/igor.suvorov\n"
"https://tWitter.com/suvorovigor\n"
"https://telegram.me/skillbranch\n"
"@skillbranch\n"
"https://vk.com/skillbranch\n"
"https://vk.com/skillbranch?w=wall-117903599_1076")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")