const regex = /^(@)?(https?:)?(\/\/)?(www\.)?(([a-z0-9\p{L}][a-z0-9\p{L}-\.]{1,61})([a-z0-9\p{L}]\.[a-z0-9\p{L}][a-z\p{L}-])*([a-z0-9\p{L}])+\/)?(#!\/)?([a-z0-9][a-z0-9.]{1,61})([\/|\?].*)*$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(@)?(https?:)?(\\\/\\\/)?(www\\.)?(([a-z0-9\\p{L}][a-z0-9\\p{L}-\\.]{1,61})([a-z0-9\\p{L}]\\.[a-z0-9\\p{L}][a-z\\p{L}-])*([a-z0-9\\p{L}])+\\\/)?(#!\\\/)?([a-z0-9][a-z0-9.]{1,61})([\\\/|\\?].*)*$', 'gmi')
const str = `http://xn--80adtDgbbrh1bc.xn--p1ai/pavel.durov
http://www.twitter.com/codeschool
https://www.twitter.com/dssd
http://www.twitter.com/#!/donttrythis
http://twitter.com/KimKardashian
http://www.twitter.com/#!/KourtneyKardash/following
http://twitter.com/#!/jasonterry31/lists/memberships
https://vk.com/igor.suvorov
https://tWitter.com/suvorovigor
https://telegram.me/skillbranch
@skillbranch
https://vk.com/skillbranch
https://vk.com/skillbranch?w=wall-117903599_1076`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}