// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^(@)?(https?:)?(\/\/)?(www\.)?(([a-z0-9\p{L}][a-z0-9\p{L}-\.]{1,61})([a-z0-9\p{L}]\.[a-z0-9\p{L}][a-z\p{L}-])*([a-z0-9\p{L}])+\/)?(#!\/)?([a-z0-9][a-z0-9.]{1,61})([\/|\?].*)*$").unwrap();
let string = "http://xn--80adtDgbbrh1bc.xn--p1ai/pavel.durov
http://www.twitter.com/codeschool
https://www.twitter.com/dssd
http://www.twitter.com/#!/donttrythis
http://twitter.com/KimKardashian
http://www.twitter.com/#!/KourtneyKardash/following
http://twitter.com/#!/jasonterry31/lists/memberships
https://vk.com/igor.suvorov
https://tWitter.com/suvorovigor
https://telegram.me/skillbranch
@skillbranch
https://vk.com/skillbranch
https://vk.com/skillbranch?w=wall-117903599_1076";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}