#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(ABC[#:*$]+(?:\w+[#:*$]+){2}|DEF[#:*$]+(?:\w+[#:*$]+){3})([^#:*$]+)(.+)"
Local $sString = "ABC#12#3#LINE1####1234678985$" & @CRLF & _
"DEF#XY#Z:1234:1234561230$" & @CRLF & _
"ABC#12#3#LINE TWO####1234678985$" & @CRLF & _
"DEF#XY#Z:1234:4564561230$" & @CRLF & _
"ABC#12#3#3RD LINE####1234678985$" & @CRLF & _
"DEF#XY#Z*1234:7894561230$"
Local $sSubst = "\1 + replacement + \3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)