# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(ABC[#:*$]+(?:\w+[#:*$]+){2}|DEF[#:*$]+(?:\w+[#:*$]+){3})([^#:*$]+)(.+)"
test_str = ("ABC#12#3#LINE1####1234678985$\n"
"DEF#XY#Z:1234:1234561230$\n"
"ABC#12#3#LINE TWO####1234678985$\n"
"DEF#XY#Z:1234:4564561230$\n"
"ABC#12#3#3RD LINE####1234678985$\n"
"DEF#XY#Z*1234:7894561230$")
subst = "\\1 + replacement + \\3"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.