package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(ABC[#:*$]+(?:\w+[#:*$]+){2}|DEF[#:*$]+(?:\w+[#:*$]+){3})([^#:*$]+)(.+)`)
var str = `ABC#12#3#LINE1####1234678985$
DEF#XY#Z:1234:1234561230$
ABC#12#3#LINE TWO####1234678985$
DEF#XY#Z:1234:4564561230$
ABC#12#3#3RD LINE####1234678985$
DEF#XY#Z*1234:7894561230$`
var substitution = "\1 + replacement + \3"
fmt.Println(re.ReplaceAllString(str, substitution))
}