use strict;
my $str = 'ABC#12#3#LINE1####1234678985$
DEF#XY#Z:1234:1234561230$
ABC#12#3#LINE TWO####1234678985$
DEF#XY#Z:1234:4564561230$
ABC#12#3#3RD LINE####1234678985$
DEF#XY#Z*1234:7894561230$';
my $regex = qr/(ABC[#:*$]+(?:\w+[#:*$]+){2}|DEF[#:*$]+(?:\w+[#:*$]+){3})([^#:*$]+)(.+)/p;
my $subst = '\\1 + replacement + \\3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";