#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:\d+[dD]\d+|\d+\s*[*+-]\s*\d+[dD]\d+)(?:\s*[*+-]\s*(?:\d+[dD]\d+|\d+))*"
Local $sString = "1d6" & @CRLF & _
"10d6" & @CRLF & _
"10d10" & @CRLF & _
"3+10d10" & @CRLF & _
"1d4+1d6+1d10" & @CRLF & _
"1d6+1" & @CRLF & _
"1d6 + 1" & @CRLF & _
"1d6+ 1" & @CRLF & _
"1d6 +1" & @CRLF & _
"1d6+3+1d10" & @CRLF & _
"1-1d4+2d3*2 * 3" & @CRLF & _
"" & @CRLF & _
"1d4 1d4 // two singly matched groups" & @CRLF & _
"1d4 + + - 3 // doesn't match crazy" & @CRLF & _
"1 // doesn't match single numbers" & @CRLF & _
"12 34 // doesn't match single numbers" & @CRLF & _
"1+3+3-1 // doesn't match math expressions with no dice"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")