# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:\d+[dD]\d+|\d+\s*[*+-]\s*\d+[dD]\d+)(?:\s*[*+-]\s*(?:\d+[dD]\d+|\d+))*"
test_str = ("1d6\n"
"10d6\n"
"10d10\n"
"3+10d10\n"
"1d4+1d6+1d10\n"
"1d6+1\n"
"1d6 + 1\n"
"1d6+ 1\n"
"1d6 +1\n"
"1d6+3+1d10\n"
"1-1d4+2d3*2 * 3\n\n"
"1d4 1d4 // two singly matched groups\n"
"1d4 + + - 3 // doesn't match crazy\n"
"1 // doesn't match single numbers\n"
"12 34 // doesn't match single numbers\n"
"1+3+3-1 // doesn't match math expressions with no dice")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.