using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:\d+[dD]\d+|\d+\s*[*+-]\s*\d+[dD]\d+)(?:\s*[*+-]\s*(?:\d+[dD]\d+|\d+))*";
string input = @"1d6
10d6
10d10
3+10d10
1d4+1d6+1d10
1d6+1
1d6 + 1
1d6+ 1
1d6 +1
1d6+3+1d10
1-1d4+2d3*2 * 3
1d4 1d4 // two singly matched groups
1d4 + + - 3 // doesn't match crazy
1 // doesn't match single numbers
12 34 // doesn't match single numbers
1+3+3-1 // doesn't match math expressions with no dice";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}