import Foundation
let pattern = #"(?:\d+[dD]\d+|\d+\s*[*+-]\s*\d+[dD]\d+)(?:\s*[*+-]\s*(?:\d+[dD]\d+|\d+))*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1d6
10d6
10d10
3+10d10
1d4+1d6+1d10
1d6+1
1d6 + 1
1d6+ 1
1d6 +1
1d6+3+1d10
1-1d4+2d3*2 * 3
1d4 1d4 // two singly matched groups
1d4 + + - 3 // doesn't match crazy
1 // doesn't match single numbers
12 34 // doesn't match single numbers
1+3+3-1 // doesn't match math expressions with no dice
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)