import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\d+[dD]\\d+|\\d+\\s*[*+-]\\s*\\d+[dD]\\d+)(?:\\s*[*+-]\\s*(?:\\d+[dD]\\d+|\\d+))*";
final String string = "1d6\n"
+ "10d6\n"
+ "10d10\n"
+ "3+10d10\n"
+ "1d4+1d6+1d10\n"
+ "1d6+1\n"
+ "1d6 + 1\n"
+ "1d6+ 1\n"
+ "1d6 +1\n"
+ "1d6+3+1d10\n"
+ "1-1d4+2d3*2 * 3\n\n"
+ "1d4 1d4 // two singly matched groups\n"
+ "1d4 + + - 3 // doesn't match crazy\n"
+ "1 // doesn't match single numbers\n"
+ "12 34 // doesn't match single numbers\n"
+ "1+3+3-1 // doesn't match math expressions with no dice";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}