using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?<r1>[\d.]+)*(?:(?:=| +)(?<r2>[\d.]+))?";
string input = @"5550.00
5550.00=11100.00
10740.00";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}