$re = '/^(?<r1>[\d.]+)*(?:(?:=| +)(?<r2>[\d.]+))?/m';
$str = '5550.00
5550.00=11100.00
10740.00';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);