package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<r1>[\d.]+)*(?:(?:=| +)(?<r2>[\d.]+))?`)
var str = `5550.00
5550.00=11100.00
10740.00`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}