// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?<r1>[\d.]+)*(?:(?:=| +)(?<r2>[\d.]+))?").unwrap();
let string = "5550.00
5550.00=11100.00
10740.00";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}